Wednesday, February 4, 2009

11.5.9 & JDK 5 - Mutually exclusive

Apps Configuration

Oracle Apps Version ==> 11.5.9
Node Type ==> Multi-node
RAC ==> No
OS & version ==> Sun SPARC Solaris (64-Bit) 10 (5.10)

Issue

Recently (last week, to be precise), I was researching an "Internal Server error" while opening Installed Base.

The error log had error "client denied by server configuration" (not very helpful, I would say). The mod_jserv.log was much more informative and in fact, quite specific. Refer the note marked in red below.
__________________________________________________________________

[28/01/2009 06:39:44:223] (ERROR) ajp12: Servlet Error: OracleJSP: oracle.jsp.provider.JspCompileException: <H3>Errors compiling$COMMON_TOP/_pages/_oa__html//_csiSwitchRespMain.java<
/H3><TABLE BORDER=1 WIDTH=100%><TR><TH ALIGN=CENTER>Line #</TH><TH ALIGN=CENTER>Error</TH></TR><TR><TD WIDTH=7% VALIGN=TOP><P ALIGN=CENTER>990</TD><TD> as of release 1.5, 'enum' is a keyword, and may not be used as an identifier (try -source 1.4 or lower to use 'enum' as an identifier) Enumeration enum = request.getParameterNames(); </TD></TR><TR><TD WIDTH=7% VALIGN=TOP><P ALIGN=CENTER>991</TD><TD> as of release 1.5, 'enum' is a keyword, and may not be used as an identifier (try -source 1.4 or lower to use 'enum' as an identifier) while (enum.hasMoreElements()) </TD></TR><TR><TD WIDTH=7% VALIGN=TOP><P ALIGN=CENTER>993</TD><TD> as of release 1.5, 'enum' is a keyword, and may not be used as an identifier (try -source 1.4 or lower to use 'enum' as an identifier) String param = (String)enum.nextElement();
__________________________________________________________________

Research

Now, the above error gave me an idea. I decided to check the Metalink Note 300482.1 - Overview of Using Java with Oracle E-Business Suite Release 11i.

This note clearly states that for 11.5.9, the JDK (Java SE) version supported is 1.4.2.

Does that mean that JDK 5 and JDK 6 are not supported for 11.5.9? Not quite, as I found out.

The Note 304099.1 (Using J2SE Version 5.0 with Oracle E-Business Suite 11i) does NOT mention 11.5.9 anywhere, implying that JDK 5 is indeed not supported with 11.5.9.

However, the Note 401561.1 (Using J2SE Version 6 with Oracle E-Business Suite 11i) does mention that JDK 6 can be used with 11.5.9 provided (yes, as the ads say - conditions apply!) that you "ensure that your E-Business Suite Release 11i system has been upgraded to Maintenance Pack 11.5.9 CU2 or higher with ATG_PF.H RUP5 or higher on the 11.5.9 stream."

Conclusion

This means that 11.5.9 is indeed supported with JDK 6 but NOT JDK 5 (of course, provided that the above conditions are satisfied).

Because, 11.5.9 is NOT supported with JDK 5, I believe we are hitting the above issue (internal server error in installed base). As of now, there is no solution to this issue apart from
1. downgrading JDK from 5 to 1.4.2
2. modifying the xml to point to 1.4.2
3. running autoconfig to ensure the changes are reflected.

Signing off now hoping that the above solution works!

No comments: