Find the number of CPUs and RAM size in UNIX

I have tried to collate commands to find the number of CPUs and total physical memory (RAM) size in all common flavours of UNIX in one blog entry. This certainly is not an exhaustive list and will be modified as and when I find new commands. You are also more than welcome to add to this list.



Number of CPUs



Sun SPARC Solaris


1. prtconf | grep cpu | wc -l


2. psrinfo | wc -l


3. psrinfo -v | grep "Status of" | wc -l


4. psrinfo -vp


5. prtdiag | grep "on-line" | wc -l


6. mpstat | grep -vi cpu | wc -l




Linux


1. grep "processor"/proc/cpuinfo | wc -l




HP-UX


1. ioscan -kfnC processor | grep "processor" | wc -l


2. sar -M 1 | awk 'END {print NR-5}'


3. sar -Mu 1 1 | awk 'END {print NR-5}'


4. ioscan -kf | grep -c processor


5. cat /var/adm/syslog/syslog.log | grep processor | grep "vmunix" | wc -l



AIX


1. lscfg -vp | grep proc | wc -l


2. lparstat -i | grep "Online Virtual CPUs" | cut -d ':' -f2


3. lsdev -C | grep Process | wc -l


4. lsdev -Ccprocessor | grep -ci available




Total Physical Memory (RAM) Size


Solaris


1. prtdiag | grep "Memory size" | cut -d ':' -f2

2. prtconf | grep "Memory size" | cut -d ':' -f2


Linux

1. echo "$(free -mt | grep "Mem:" | awk '{print $2}' | tr -d [:space:]) MB"

or

free -mt | grep "Mem:" | awk '{print $2}' | tr -d [:space:];echo " MB"

2. grep MemTotal /proc/meminfo | cut -d ':' -f2


HP-UX

1. echo "selclass qualifier memory;info;wait;infolog" | /usr/sbin/cstm | grep "Total Configured Memory" | cut -d ':' -f2

2. echo "$(grep Physical /var/adm/syslog/syslog.log | awk '{print $7}') KB"


AIX

1. echo "$(lsattr -El mem0 | grep "Total" | awk '{print $2}') MB"

2. lsattr -El mem0 | grep "Total" | awk '{print $2}'; echo " MB"



Comments

Popular posts from this blog

java.lang.ExceptionInInitializerError while trying to Access login page

Solution to "End Program - WMS Idle"

WGET shell Script for downloading patches